On Mon, Aug 08, 2016 at 09:46:55AM +0200, Petr Cech wrote:
On 08/04/2016 05:01 PM, Petr Cech wrote:
> On 08/04/2016 04:35 PM, Petr Cech wrote:
> > Hi list,
> > there is the first version of patch for . I need
> > to investigate if we have the same issue in other
> > *_childs.
> > I tested it with sleep() added into ldap_child code.
> >  https://fedorahosted.org/sssd/ticket/3106
> I know, it is not perfect. For example 2 seconds between SIGTERM and
> SIGKILL should be constant. I will send the second version with other
> childs, but not today.
there is fixed patch set. There is only one minor change -- constant for
time between signals.
Is there better name for global_ccname_file_dummy? I did not want to break
the naming... but it looks really long.
I think this name is fine, but I would prefer to not use the variable in
the code, except for setting it after the temporary file is created and
then set the variable back to NULL after the temporary file is renamed
to the real one.
> I looked at code of others children. I saw the same schema at
> src/providers/ad/ad_gpo_child.c:361 (temporary file renamed to solid one).
> In my opinion we could fix ad_qpo_child in next patch (not the highest
> priority for now) and make SIGTERM/SIGKILL more general. Maybe all child
> processes could have it.
> Petr^4 Čech