I'm sending updated patch:
I would personally prefer not to delete the above sentence
just rephrase it. Sorry for nitpicking, but I know that the schema
differences have been a cause of confusion among users, so I think we
should keep the documentation as descriptive as possible.
You're probably right. Done.
This would better be answered by a native English speaker, but
object" does not sound right to me, is just "parent object" better?
I think it is correct this way. As you said, native English speaker should
probably decide this.
Also, In description of most of the added ldap_user_* attributes, I
think that "this parameter" would sound better than just "this".
This option is already described in sssd.conf since it is used by
proxy backend, too.
I'm wondering whether this should be considered a generic
similar to entry_cache_timeout and documented in sssd.conf. I think any
future back ends might implement a cleanup task, too, controlled by the
same parameter, even though LDAP is the only implemented ID provider so