On 04/12/2010 05:09 PM, Dmitri Pal wrote:
> Jakub Hrozek wrote:
>> On 04/10/2010 01:45 AM, Dmitri Pal wrote:
>>> Dmitri Pal wrote:
>>>> Addresses ticket https://fedorahosted.org/sssd/ticket/447
>>>> Applies only on to of my previous ini metadata patch.
>>> Forgot to say that this is a patch in the title.
>> Nack, this does not compile with the default settings which do not have
>> HAVE_TRACE #defined, you need to add #define TRACE_LNUMBER(level, msg,
>> num) for that case, too.
> The attached patch addresses the issue and adds other macros for signed
The code seems to be OK now, but when you added the signed/unsigned
division it seems to me that more common naming scheme is to treat
signed as implicit and unsigned as explicit...i.e:
TRACE_NUMBER = signed int
TRACE_UNUMBER = unsigned int
TRACE_LNUMBER = signed long int
TRACE_ULNUMBER = unsinged long int
But that's just a suggestion, not a hard nack..
I thought of that too but that
would require a lot of changes to
So I checked with Steven and we agreed to go with the scheme I implemented.
sssd-devel mailing list
Engineering Manager IPA project,
Red Hat Inc.
Looking to carve out IT costs?