On Fri, May 10, 2013 at 03:08:51PM +0200, Pavel Březina wrote:
Here is the API implementing current design document.
be_ptask.h is missing documentation of public interface. I'll amend the
patch once the design document is fully acked.
Sorry I got back to you after long delay. The design document looks good
to me, I only have one question: do you think there is value in having
separate enabled_delay and first_delay? Can we unify them?
Can you add some comments to the header file (copied from the design
I haven't tried it yet, I'll do that when implementing
periodical refresh of expired records.
From 1be2a8113cc3bff5b8b142482732a1f898412d4e Mon Sep 17 00:00:00
From: =?UTF-8?q?Pavel=20B=C5=99ezina?= <pbrezina(a)redhat.com>
Date: Fri, 26 Apr 2013 14:02:11 +0200
Subject: [PATCH] back end: periodic task API
The code looks good to me after first read, but can you use the same
file prefix as the rest of the generic interface files? (dp_ not be_).
Makefile.am | 2 +
src/providers/be_ptask.c | 344 +++++++++++++++++++++++++++++++++++++++++++++++
src/providers/be_ptask.h | 67 +++++++++
src/util/util_errors.c | 1 +
src/util/util_errors.h | 1 +
5 files changed, 415 insertions(+)
create mode 100644 src/providers/be_ptask.c
create mode 100644 src/providers/be_ptask.h