On Fri, Jun 20, 2014 at 5:10 PM, Jakub Hrozek <jhrozek@redhat.com> wrote:
This patch needs rebasing on current master. For the sake of review, I
rebased it locally -- mostly it was trivial "use both" case.

The functionality is fine, make, make check and make distcheck all pass.

On Tue, Mar 04, 2014 at 09:37:54AM +0200, Noam Meltzer wrote:
> ---
>  Makefile.am                 | 19 +++++++++++++++++++
>  configure.ac                | 10 ++++++++++
>  src/conf_macros.m4          | 30 ++++++++++++++++++++++++++++++
>  src/external/libnfsidmap.m4 | 17 +++++++++++++++++
>  4 files changed, 76 insertions(+)
>  create mode 100644 src/external/libnfsidmap.m4
>
> diff --git a/Makefile.am b/Makefile.am
> index 9f010d9..23f6093 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -47,6 +47,7 @@ localedir = @localedir@
>  nsslibdir = @nsslibdir@
>  pamlibdir = @pammoddir@
>  autofslibdir = @appmodpath@
> +nfslibdir = @nfsidmaplibdir@
>
>  dbpath = @dbpath@
>  pluginpath = @pluginpath@
> @@ -526,6 +527,7 @@ dist_noinst_HEADERS = \
>      src/tests/cmocka/common_mock_sysdb_objects.h \
>      src/sss_client/ssh/sss_ssh_client.h \
>      src/sss_client/sudo/sss_sudo.h \
> +    src/sss_client/nfs/nfsidmap_internal.h \
>      src/lib/idmap/sss_idmap_private.h
>
>
> @@ -1666,6 +1668,23 @@ libnss_sss_la_LDFLAGS = \
>      -version-info 2:0:0 \
>      -Wl,--version-script,$(srcdir)/src/sss_client/sss_nss.exports
>
> +
> +if BUILD_NFS
> +nfslib_LTLIBRARIES = sss_nfs.la
> +sss_nfs_la_SOURCES = \
> +    src/sss_client/common.c \
> +    src/sss_client/nss_mc_common.c \
> +    src/util/io.c \
> +    src/util/murmurhash3.c \
> +    src/sss_client/nss_mc_passwd.c \
> +    src/sss_client/nss_mc_group.c \
> +    src/sss_client/nfs/sss_nfs_client.c \
> +    $(NULL)
> +sss_nfs_la_CFLAGS = $(AM_CFLAGS)
> +sss_nfs_la_LIBADD = $(CLIENT_LIBS) $(NFSIDMAP_LIBS)
> +sss_nfs_la_LDFLAGS = -module -avoid-version

I know this is serious bikeshedding, but With CFLAGS, LIBADD and LDFLAGS
could you use the same format we use elsewhere?

sss_nfs_la_LIBADD = \
    $(CLIENT_LIBS) \
    $(NFSIDMAP_LIBS)

I'm not too keen about the format itself, but being consistent is good
for maintenance :-)
sure.
 

The rest looks good to me.