On Thu, 2012-11-22 at 15:19 -0500, Simo Sorce wrote:
While working on a different refactoring patch I came across the
krb5_child code and found it very hard to read and follow due to the
growth it has gone through in the past.
I couldn't force myself not to refactor it to make it more linear and
easier to follow and read. A bunch of dead stuff that really confused me
initially also got removed.
(I propose this for master only)
Sorry, just noticed the name of a function got out wrong (k5_send_data
instead of k5c_send_data). Amended patch attached.
Simo Sorce * Red Hat, Inc * New York