[golang-github-gorilla-mux/f19] revert golang >= 1.2 version requirement