I had a pending patch for a rename of 'ensure_gpgcheck_never_disabled'
to 'yum_gpgcheck_never_disabled'. However, Jeff deleted the check as
part of a make validate cleanup. I'll ACK this (which reinstates the
original check), but I think the check should be renamed to more closely
match the existing related check 'yum_gpgcheck_global_activation'.