Jason Guiditta wrote, at 02/24/2010 11:39 PM +9:00:
That is great that you have a work around for rawhide, but since I am
running f12, I am more interested at the moment in the rack version
downgrade there. Should I just file a BZ against the Rack gem, or have
you already spoken to the maintainer?
Filing a bug against rubygem-rack is preferable so that we can keep
track of this issue.
FYI, just doing a little more
poking now, there are others outside fedora land who have hit this. I
have links below for some of the discussion (as recent as 2 days ago),
but the gist is that rails does not want to guarantee it runs on >1.0.x
because rack could introduce api breakage.
Well, actually API of rack really changed between 1.0.0 and 1.1.0 and
for rubygem-actionpack just changing the dependency on rack from ~>
to >= does _not_ fix this issue (as I posted in bug 552972, after
just changing ~> to >= we will see many test failures on actionpack)
By the way you can see my workaround patch for actionpack 2.3.4 on:
This means we can not expect
rails to be changing their gemspec to accommodate a wider range of
versions, and a ticket has been filed against rubygems itself.
I don't think this is rubygem's problem. It is just that rack 1.1.x
and actionpack 2.3.x are not compatible.
there is talk of rails using bundler to get around this issue, which,
from the little I know about it, screams maven (and therefore makes me
think there will be even more issues coming up for rails in fedora).
For instance, if you try to run a rails app in thin (which is now in
fedora), and it loads rack 1.1 (it will load the latest you have
installed), then rails will die because it tries to load 1.0.1 after 1.1
is already loaded.
For me this is saying only that rack 1.1 should not be installed when
using rails 2.3.x regardless of whether thin is to be used or not,
or if rack 1.1 is definitely needed actionpack should be patched.
rails position, explained by core commiter, yehuda katz:
On Tue, Feb 23, 2010 at 9:41 PM, Mamoru Tasaka
<mtasaka(a)ioa.s.u-tokyo.ac.jp <mailto:firstname.lastname@example.org>> wrote:
Mamoru Tasaka wrote, at 02/24/2010 11:06 AM +9:00:
> Jason Guiditta wrote, at 02/24/2010 06:47 AM +9:00:
>> I am running Fedora 12 with Rails 2.3.4 installed. Everything was
>> working fine, then last night I got an update from yum for Rack 1.1.
>> After installing that, my working rails apps failed to load.
>> a new test app yielded:
>> RubyGem version error: rack(1.1.0 not ~> 1.0.0) (Gem::LoadError)
>> Has anyone else hit this issue? If more detail is needed, let
> Well, as I already posted on
> rack 1.1.0 is not compatible with rails 2.3.x.
> I added some workarounds on rawhide rails, however for F-12 we
may have to
> consider to downgrade rack to 1.0.0.
Well, actually workaround is in rubygem-actionpack, which
rubygem-rails depends on.
Also please check
(already marked as "CLOSED RAWHIDE")