> You should skip the key when invoking rosdep (--skip-keys) and install the package manually via pip.

 --skip-keys was part of the command:
rosdep install --from-paths src --ignore-src --rosdistro dashing -y --skip-keys "console_bridge fastcdr fastrtps libopensplice67 libopensplice69 rti-connext-dds-5.3.1 urdfdom_headers"

I meant that python3-pep8 should be added to --skip-keys, like this: rosdep install --from-paths src --ignore-src --rosdistro dashing -y --skip-keys "console_bridge fastcdr fastrtps libopensplice67 libopensplice69 rti-connext-dds-5.3.1 urdfdom_headers python3-pep8"

I tried with foxy, same error:
rosdep install --from-paths src --ignore-src --rosdistro foxy -y --skip-keys "console_bridge fastcdr fastrtps libopensplice67 libopensplice69 rti-connext-dds-5.3.1 urdfdom_headers"
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
ament_pep8: No definition of [python3-pep8] for OS version [32]

The --rosdistro argument to rosdep is really only useful on Ubuntu right now, and I don't think it does what you want it to do even when it does work. You need to update the sources in your src directory to Foxy. The ament_pep8 package doesn't exist in Foxy, so the sources are definitely older than Foxy.

Thanks for the tip I'm brand new to ROS trying to get it set up for courses in September. 

Thanks for the reply Scott, I'm feeling more hopeful. Could it be a Python version issues, e.g., Fedora's Python vs Anaconda Python?

Whichever Python version is used when you invoke the "python3" executable is the one that ROS 2 will use, I believe.

BTW, are questions about Gazebo allowed? Using X2Go it segfaults and I posted that here: https://bugs.launchpad.net/sr-ros-interface/+bug/1891654

For questions like this, you should really post on https://answers.ros.org and https://answers.gazebosim.org. I think this list is intended more for discussion than support.

Yes I did on the latter, no response.  

Now another failure in the next step. "Build the code in the workspace" I'm getting the pthreads error, which I've seen 

I had to specify a couple variables to get the catkin_make_isolated command to run so I got this:
./src/catkin/bin/catkin_make_isolated -DPYTHON_EXECUTABLE=/usr/local/bin/anaconda3/bin/python -DPYTHON_INCLUDE_DIR=/usr/local/bin/anaconda3/include/python3.7m  --install -DCMAKE_BUILD_TYPE=Release

<== Failed to process package 'gl_dependency':
  Command '['/root/ros_catkin_ws/install_isolated/env.sh', 'cmake', '/root/ros_catkin_ws/src/gl_dependency', '-DCATKIN_DEVEL_PREFIX=/root/ros_catkin_ws/devel_isolated/gl_dependency', '-DCMAKE_INSTALL_PREFIX=/root/ros_catkin_ws/install_isolated', '-DPYTHON_EXECUTABLE=/usr/local/bin/anaconda3/bin/python', '-DPYTHON_INCLUDE_DIR=/usr/local/bin/anaconda3/include/python3.7m', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1.

Reproduce this error by running:
==> cd /root/ros_catkin_ws/build_isolated/gl_dependency && /root/ros_catkin_ws/install_isolated/env.sh cmake /root/ros_catkin_ws/src/gl_dependency -DCATKIN_DEVEL_PREFIX=/root/ros_catkin_ws/devel_isolated/gl_dependency -DCMAKE_INSTALL_PREFIX=/root/ros_catkin_ws/install_isolated -DPYTHON_EXECUTABLE=/usr/local/bin/anaconda3/bin/python -DPYTHON_INCLUDE_DIR=/usr/local/bin/anaconda3/include/python3.7m -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'
Command failed, exiting.

Determining if the function pthread_create exists in the pthreads failed with the following output:
Change Dir: /root/ros_catkin_ws/build_isolated/gl_dependency/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/gmake cmTC_a7185/fast && /usr/bin/gmake  -f CMakeFiles/cmTC_a7185.dir/build.make CMakeFiles/cmTC_a7185.dir/build
gmake[1]: Entering directory '/root/ros_catkin_ws/build_isolated/gl_dependency/CMakeFiles/CMakeTmp'
Building C object CMakeFiles/cmTC_a7185.dir/CheckFunctionExists.c.o
/usr/bin/cc   -DCHECK_FUNCTION_EXISTS=pthread_create   -o CMakeFiles/cmTC_a7185.dir/CheckFunctionExists.c.o   -c /usr/share/cmake/Modules/CheckFunctionExists.c
Linking C executable cmTC_a7185
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_a7185.dir/link.txt --verbose=1
/usr/bin/cc  -DCHECK_FUNCTION_EXISTS=pthread_create    -rdynamic CMakeFiles/cmTC_a7185.dir/CheckFunctionExists.c.o  -o cmTC_a7185  -lpthreads
/usr/bin/ld: cannot find -lpthreads
collect2: error: ld returned 1 exit status
gmake[1]: *** [CMakeFiles/cmTC_a7185.dir/build.make:107: cmTC_a7185] Error 1
gmake[1]: Leaving directory '/root/ros_catkin_ws/build_isolated/gl_dependency/CMakeFiles/CMakeTmp'
gmake: *** [Makefile:141: cmTC_a7185/fast] Error 2

Is there some workaround changing out the pthread? I just don't know where to look.