chris.stone(a)gmail.com ("Christopher Stone") writes:
On 7/5/06, Enrico Scholz
> Ok; a more realistic example: you have an application for Fedora
> Extras which requires bind, version 9.3 or later. What would you
> a) Requires: bind >= 9.3?
> When your answer is a): this requirement would be fulfilled by FE3 with
> its bind 9.2.1 too, so this answer would be wrong.
The answer is a. If it doesn't work on FE3 then I would be surprised,
and it should be fixed by the legacy team for FE3.
This application can not work in FE3 because it requires bind, version
9.3 but FE3 has 9.2.4 only (the 9.2.1 above was wrong; sorry).
With current rpm you can express package (but not version) dependencies
only. Therefore, the Requires: above would be fulfilled in FE3 because it
has bind-20:9.2.4 which is newer than bind-9.3 (which will be interpreted
as bind-0:9.3 nowadays).