tibbs(a)math.uh.edu (Jason L Tibbitts III) writes:
ES> * I do not say that versioned dependency shall be forbidden;
ES> just do not make sense and I am against a rule like
| If these versions are specified by the package, they should be
| indicated in the spec file (IMO).
This makes no sense to me. So if Red Hat bumps the FC5 PHP from 5.1.4
to 5.1.5 to fix some bug and a package requires that fixed version,
what is it supposed to require?
In this case you you will have to use a versioned dependency but this is
different from "specified by the package".
E.g. when php-5.1.4-1 has a bug which will be fixed by a patch (which
fixes only this issue without a full version upgrade) you have to write
| Requires: php >= 5.1.4-2
and can not follow README which says that 5.1.5 will be required.
The version in the Requires: depends on the environment but not on the
requirement told by the (upstream) package.
In the discussed case, the version in "php >= 4.2.0" is redundant in FE
environments and except for 3rd party repository-support there is no
reason to use it resp. to enforce it.