This is an automatically generated e-mail. To reply, visit: http://reviewboard-openlmi.rhcloud.com/r/1667/

src/software-dbus/LMI_ResourceForSoftwareIdentityProvider.c (Diff revision 1)
45
    char elem_name[ELEM_NAME_LEN] = "", instance_id[INSTANCE_ID_LEN] = "";
It's usually better for readability to put these on separate lines.

src/software-dbus/LMI_ResourceForSoftwareIdentityProvider.c (Diff revision 1)
109
                ORGID "_" SW_IDENTITY_RESOURCE_CLASS_NAME);
Please, use LMI_ORGID from the common library.

src/software-dbus/LMI_ResourceForSoftwareIdentityProvider.c (Diff revision 1)
256
            ORGID "_" SW_IDENTITY_RESOURCE_CLASS_NAME) != 0) {
LMI_ORGID.

src/software-dbus/LMI_ResourceForSoftwareIdentityProvider.c (Diff revision 1)
472
            ORGID "_" RESOURCE_FOR_SW_IDENTITY_CLASS_NAME)) {
LMI_ORGID.

src/software-dbus/LMI_ResourceForSoftwareIdentityProvider.c (Diff revision 1)
476
    if (CMClassPathIsA(_cb, cop, ORGID "_" SW_IDENTITY_RESOURCE_CLASS_NAME, &st)) {
LMI_ORGID.

src/software-dbus/LMI_ResourceForSoftwareIdentityProvider.c (Diff revision 1)
591
    if (!cm_class_is_a(_cb, KNameSpace(cop), assocClass,
There's newly lmi_class_path_is_a() in openlmicommon.

src/software-dbus/sw-utils.h (Diff revision 1)
42
#define SW_IDENTITY_CLASS_NAME "SoftwareIdentity"
44
#define SW_IDENTITY_CLASS_NAME "SoftwareIdentity"
43
#define SYSTEM_SW_COLLECTION_CLASS_NAME "SystemSoftwareCollection"
45
#define SYSTEM_SW_COLLECTION_CLASS_NAME "SystemSoftwareCollection"
44
#define SW_IDENTITY_RESOURCE_CLASS_NAME "SoftwareIdentityResource"
46
#define SW_IDENTITY_RESOURCE_CLASS_NAME "SoftwareIdentityResource"
45
#define MEM_SW_COLL_CLASS_NAME "MemberOfSoftwareCollection"
47
#define MEM_SW_COLL_CLASS_NAME "MemberOfSoftwareCollection"
46
#define INST_SW_IDENTITY_CLASS_NAME "InstalledSoftwareIdentity"
48
#define INST_SW_IDENTITY_CLASS_NAME "InstalledSoftwareIdentity"
49
#define RESOURCE_FOR_SW_IDENTITY_CLASS_NAME "ResourceForSoftwareIdentity"
All of these should be already defined by konkret.

src/software-dbus/sw-utils.c (Diff revision 1)
done:
447
            warn(error_msg);
lmi_warn().

Perhaps you forgot to rebase before submitting the review?

- Jan Synacek


On May 5th, 2014, 5:27 p.m. CEST, Peter Schiffer wrote:

Review request for OpenLMI Developers.
By Peter Schiffer.

Updated May 5, 2014, 5:27 p.m.

Repository: openlmi-providers

Description

Software-dbus: implemented LMI_ResourceForSoftwareIdentityProvider

Diffs

  • src/software-dbus/LMI_ResourceForSoftwareIdentityProvider.c (9332f62e392103e39a700cedcfaadf72df8e5f53)
  • src/software-dbus/LMI_SoftwareIdentityProvider.c (7e03badf0113ebc981a24d20ccac60131dfb8d74)
  • src/software-dbus/LMI_SoftwareIdentityResourceProvider.c (fec2794131a6194510364e45969995729e80108c)
  • src/software-dbus/sw-utils.h (16e6ca11e4714ab337c7e554f7c8ced5b06bd37b)
  • src/software-dbus/sw-utils.c (76ca58bd0129c3d12695d22da77fb3613c8685b1)

View Diff