This is an automatically generated e-mail. To reply, visit: http://reviewboard-openlmi.rhcloud.com/r/473/

On July 1st, 2013, 7:29 a.m. UTC, Roman Rakus wrote:

src/hardware/dmidecode.c (Diff revision 1)
short dmi_get_pointing_devices(DmiPointingDevice **devices, unsigned *devices_nb)
1972
            ret = -8;
1972
            ret = -5;
What is this magic number? Better use some enum.

On July 1st, 2013, 11:11 a.m. UTC, Peter Schiffer wrote:

These numbers.. they don't matter. Only important thing is that they are negative. I used different numbers in the beginning when I had to debug often, and I haven't changed it since then. To "fix" this, changing all these numbers to the -1 would be enough. Enum could work too, but that would require more work, which is currently not worth it, especially for dmidecode.c file, as there are no plans for adding more features.

So, for now, I'd just let it be. Later, I'll think about what to do with it everywhere in the hardware provider.
I see. I get your point.

- Roman


On June 27th, 2013, 9:58 a.m. UTC, Peter Schiffer wrote:

Review request for OpenLMI Developers.
By Peter Schiffer.

Updated June 27, 2013, 9:58 a.m.

Repository: openlmi-providers

Description

Hardware: Added battery providers

New providers:
 * LMI_BatteryProvider
 * LMI_BatteryPhysicalPackageProvider
 * LMI_PhysicalBatteryContainerProvider
 * LMI_PhysicalBatteryRealizesProvider

Diffs

  • mof/60_LMI_Hardware.mof (e22da2cb866c6a678efa1547ff896f29896dbc2e)
  • src/hardware/LMI_BatteryPhysicalPackageProvider.c (PRE-CREATION)
  • src/hardware/LMI_BatteryProvider.c (PRE-CREATION)
  • src/hardware/LMI_Hardware.h (f88e6b6bb5074cab3cc9f079898b86bb1f3a56cf)
  • src/hardware/LMI_PhysicalBatteryContainerProvider.c (PRE-CREATION)
  • src/hardware/LMI_PhysicalBatteryRealizesProvider.c (PRE-CREATION)
  • src/hardware/LMI_PointingDeviceProvider.c (f3c89d6284c6b3a33d2a8a7c0456731d3b86c04c)
  • src/hardware/dmidecode.h (34bfd473b9939c3b73c3932f463288b7d85f4ea2)
  • src/hardware/dmidecode.c (d989a094e59ffa60db06846624aadc6560887520)

View Diff