Another possibility -- corrupted kernel upon install/upgrade.

It may sound stupid, but I just experienced a similar case with the Power Management features when I did the network upgrade from F19 x64 KDE to F20 x64 KDE on my Dell D531. The kernel version embedded is 3.11.8-301. But, for some reason, it seems like part of it is corrupted or damaged somehow because hibernation doesn't work correctly. Whether it's from the menu, sudo pm-hibernate, or sudo systemctl hibernate, it would go down properly; however, when you power it on, the session's lost and it acts like it was a restart or fresh boot. [There was also a problem with several RPMs installed in it to where I couldn't install new programs because most of them were newer than what was available in the repositories.] So, out of aggravation, I did a total reformat and clean install from the F20 KDE LiveCD, only to have the same problems with hibernation.

I came across a random article in from a Yahoo! search and came across the suggestion of reinstalling the kernel. As long as you're not trying to reinstall the current one, you can do a fresh kernel install. I did a search on the Fedora buildsystem site for another available version of the kernel. I recently upgraded to 3.15.9-201.fc20.x86_64 by downloading both the kernel and the headers. Then, I just did a sudo yum localinstall kernel kernel-headers from the terminal, not from Apper (or whichever Software Management GUI you're using). Just in case, I rebooted into the new kernel I installed and tried the suspend and hibernate options. Everything worked fine. I haven't tried the current delta kernel -- 3.17.8 -- that's in the repository, but, if you do, I'd suggest doing it from the terminal with the full install as a precaution.

Hope this helps,


CS DBA wrote on 1/21/2015 6:31 PM:
Maybe as a short term fix you could go to the power management settings and set the 'event' for closing the lid to 'lock screen' instead of 'sleep'

On 01/12/2015 12:32 PM, Miguel Ángel Pérez wrote:
Hi Gilles-Philippe,

All of this seems to be the fault of the graphic driver and there is no fast solution for this. If you cannot wait for the intel guys to fix this in their driver then you could back up your data and go back to fedora 20 if it worked on your laptop.

If you can't go back, then filing the bug upstream and waiting is the only thing you can do ...

2015-01-12 19:17 GMT+01:00 Gilles-Philippe Morin <>:

I am in deep trouble now that I have upgraded to Fedora 21. My main
production computer — a Dell Inspiron 1525 laptop — fails most of the
time to resume from RAM suspend and thus I cannot use it at school

At the same time, this issue is accompanied by many graphical issues.
I do not know if they are linked together.

When I say "suspend from RAM", I mean closing the lid of my laptop.
When I say "resume from suspend", I mean opening that lid.
When I say "fail to resume", I mean getting a black screen with a
working cursor and responsive keyboard. The only buttons that don't
work are the brightness buttons and the Prnt Scrn buttons. Switching
to another TTY works.

I made many dmesg outputs, after boot, after a succeeding resume,
after a failed resume in another TTY. The latter does not provide me
anything meaningful, but the two first ones are filled with warnings.

I always get a warning for the i915 GPU DRM:

At boot, my kernel gets tainted because of a graphical warning:

After a succeeding resume, I get a firmware bug:

And finally, the very inconvenient resume fails:

I also get graphical glitches from time to time, but I have no idea if
they are related to the above bugs:

I get next to no responses in Bugzilla after weeks. The Google+
community points me to my own Bugzilla filings. The IRC tells me to
use Google. How can I solve this fast?

Here's my setup:
Fedora 21 Workstation
Processor: Intel® Pentium(R) Dual CPU T2390 @ 1.86GHz × 2
OS Type: 64-bit
Graphics: Intel® 965GM
GNOME: Version 3.14.2

I installed the following software since installation:
Age of Empires (WINE)
Google Chrome
LibreOffice 4.3
Simple Scan
Tweak Tool
World of Goo (Steam)

I am willing to give any additional information that can accelerate
the solution-finding.

Please help me, thank you.

laptop mailing list

Miguel Ángel Pérez

laptop mailing list

laptop mailing list