On 06/06/2014 06:31 PM, Vivek Goyal wrote:
On Wed, Jun 04, 2014 at 11:31:13PM +0530, Hari Bathini wrote:
>>> function rebuild_initrd()
>>> + if [ $DUMP_MODE == "fadump" ]; then
>>> + backup_default_initrd
>>> + fi
>> I would rather call it backup_fadump_initrd. This will make it much
>> clear that what initrd we are talking about.
> vivek, the intention here is to backup default initrd, for user's
> reference, before replacing it with an initrd with fadump support.
> So, I guess adding a detailed comment of why we do this could help.
Problem here is what is "default" initrd. In this context default initrd
is the one which will be used if user does not enforce one. So for fadump
case there will be one default intird and for kdump case there is another
Calling it default initrd does not mean it is boot initrd.
That's why I would rather use one global variable say "target_initrd"
and that should be set based on dump mode. I don't think using term
"default initrd" to refer to boot initrd is right/intuitive.
Hmmm.. true. Will update accordingly.