In the meantime you might give copyq 3.4.0 a try.  I pushed it to the test repositories a few days ago.  I has some wayland fixes in it.
You can read more about it here:  https://copyq.readthedocs.io/en/latest/

On Tue, May 1, 2018 at 7:03 AM, Peter Gueckel <pgueckel@gmail.com> wrote:
I tried KDE/Wayland on F27 about 6 weeks ago and found that some programs worked and others didn't, so I reverted to Xorg.

I installed F28 Sunday night (2 days ago) and I was hopeful, so I gave it another go. I think it is good enough to use now. After 2 days, I have not switched back. There are a few pesky problems. At first, I kept getting LibreOffice without a frame, so I couldn't resize the window.. I installed breeze-gtk and I also rebooted, so I'm not sure what did it, but I think it works fine now.

The biggest problem so far is the clipboard. Again, in LibreOffice, I was unable to cut and paste. As I type here, though, ctrl-c, ctrl-v and ctrl-z are working. Still, when I check the clipboard widget,there is nothing there. I have it configured as per default, not to synchronize the selection and the clipboard. So, using this setup of having the clipboard and the selection separate, how do I ever get anything into the clipboard?

Anyway, while I haven't done much yet, other than installing and configuring the system, and some browsing, I think I can use KDE with Wayland now. It has taken a long time, compared to Gnome, to get to this point, but I am glad we have finally arrived.

Any experiences or thoughts I need to watch for?
_______________________________________________
kde mailing list -- kde@lists.fedoraproject.org
To unsubscribe send an email to kde-leave@lists.fedoraproject.org