To get started with Java on Fedora 8, I installed
java-1.7.0-icedtea-devel -
as well as BlueJ using the .jar file from it's website.

Used this command to start the BlueJ installation:
/usr/lib/jvm/java-1.7.0-icedtea- -jar
This worked fine and the installation linked to
/usr/lib/jvm/java-1.7.0-icedtea- as the JDK directory.

Loaded up BlueJ, imported the first project from the CD that came with
the book. Creating new objects were no problem
at all. However, as soon as I tried to invoke a method, I got this

Here's a screenshot of BlueJ and the error as well:

Java and Javac version match:

The Java compiler can generate bytecode for different/older java runtimes.  In this case the compiler has generated code that the runtime is unable to use.

The compiler has a setting you can change. In the Eclipse IDE it is Preferences/Compiler/JDK compliance. Typically there will be a similar feature in BlueJ. It may be an option you can set via the GUI, or the IDE may allow you to pass command line parameters to the compiler.

I'd suggest the highest setting (Java 5 or 6)