The delta rpm support now looks pretty functional (at least for me). The "presto" project is now up at https://hosted.fedoraproject.org/projects/presto
Feel free to grab the code and test.
The most important missing piece of the puzzle is more testing! I would like any mirror of "updates" for FC6 to host delta rpms, so that people can start testing, reporting bugs, and we can work to fix them. Unfortunately, I don't have the means to host such a mirror! I mailed the mirror admins list, but no volunteers till now. If anyone is interested in helping with this, please contact me. The disk space required shouldn't be too much, because we could mirror just the FC6 release (only i386 as well for now), also the bandwidth required would be minimal (am I gonna get that much testers :)
It seems suse uses "_" as a separator, and will mention the version once if it is the same across the 2 rpms. For example
That would be name-verOld_verNew-relOld_relNew.arch.delta.rpm
and libextractor-0.5.10-12_12.2.i586.delta.rpm shows using a single version numberOn 2/3/07, Ahmed Kamal < email@example.com> wrote:AFAIK, suse does use .delta.rpm as can be found here
Tried to guess their naming convention, it seems something like "newVer_oldVer-release", not sure why there is a single release, and it's not even consistent. I'm trying to lookup some info on their naming convention.On 2/3/07, Toshio Kuratomi < firstname.lastname@example.org> wrote:On Fri, 2007-02-02 at 19:32 +0200, Ahmed Kamal wrote:
> One tiny thing I am facing is the naming convention to be used for the
> resulting drpms. This name needs to reflect both versions for which
> this delta was made. I am thinking I need to use something like:
> " name-VerNew-RelNew-VerOld-RelOld.arch.drpm"
> Not sure if this would cause any issues, I mean not using the standard
> rpm naming scheme. But then again, this is not a rpm, which is why I
> chose suffix .drpm instead of say .delta.rpm
> Let me know what you guys think
What does SuSE use when they generate delata-rpms? (I do like drpm
better than delta.rpm).