On 03/26/2011 09:47 PM, Sawrub wrote:
Hello All,

I just came across a blog [1] that mentioned about the off-line dictionary setup in Ubuntu. I tried doing similar in Fedora but failed. So the point for which I'm here looking for help is that though I've been able to 'yum install wordnet dictd', and I'm able to query wordnet [2] in its graphical window using
but when i'm trying to start my local dict daemon so as to map wordnet under gnome-dictionary its fails simply saying that 'no dictionaries installed'.
$ sudo service dictd restart
Shutting down dictd:                                       [FAILED]
Starting dictd: no dictionaries installed                  [FAILED]

I have googled a bit but have not been able to find a solution. Also came across [3] but that to didn't helped as the server is not coming up. Though the client side of dict is working for me [4].
Any help that makes this work would be great.

[1] http://digitizor.com/2010/02/03/how-to-install-an-offline-dictionary-in-ubuntu-2/
[2] http://wordnetweb.princeton.edu/perl/webwn
[3] http://forums.fedoraforum.org/showthread.php?t=216463
[4] http://fpaste.org/DPC7/

From Susmit [from archive]
> [3] http://forums.fedoraforum.org/showthread.php?t=216463

This link works fine for me.
Have you installed the dictionaries?

# rpm -ivh ftp://ftp.pbone.net/mirror/ftp.gwdg.de/pub/linux/misc/suser-tcousin/suse82/noarch/RPMS.Thibaut/dictd-dictionaries-1.0-2.noarch.rpm

# service dictd start
Starting dictd:                                            [  OK  ]


first of all , thanks for the response. I did tried searching for available dictionaries using
$ sudo yum search dictionaries
and it did listed a good count of them. The question still remains that why is 'wordnet' not considered, when 'dict' client does lists it in results why is the daemon failing to load/consider it.
Saurabh Sharma
Linux user number: 490644
Open your doors.......It's time to look beyond Windows