That's very possible. I ended up doing this to resolve it:

# ipa-client-install -U --uninstall
# rm -f /etc/ipa/ca.crt
# rm -rf /var/lib/sss/db/*
# yum remove sssd sssd-common ipa-client
# reboot


# yum install ipa-client
# ipa-client-install --enable-dns-updates --mkhomedir

And voila.

On 07/19/2018 11:33 AM, Lukas Slebodnik via FreeIPA-users wrote:
On (18/07/18 13:39), Bret Wortman via FreeIPA-users wrote:
I've got a system (probably more than one) where I've got clients who aren't
able to bring up SSSD due to this error, as seen in "journalctl -xe".

I've tried unenrolling & re-enrolling. I've tried unenrolling, uninstalling,
reinstalling ipa-client, and re-enrolling. I've tried unenrolling, deleting
the host records from the IPA server, then re-enrolling. I've tried
reinstalling SSSD. None have changed the behavior at all.

Does anyone know what this error refers to or is caused by?

I assume it is due to mixed version of sssd and libldb.
There was ABI change in libldb 1.1.30/1.2.0

Please provide version of these pacakges.
Or even better ensure you use up-to-date system.
(In case of external repositories it might be more complicated)

FreeIPA-users mailing list --
To unsubscribe send an email to
Fedora Code of Conduct:
List Guidelines:
List Archives: