Hi Alex,
I've been looking into this some.

What distribution do you want this for?
I haven't seen anywhere in your emails saying if this is for RHEL 8 or RHEL 9?
The spec file you have attached is for fence-agents-4.11, which is only in Fedora, so that doesn't let me know either.

The major problem is that the fence-agents-pve version has to match the fence-agents that is in your version of RHEL.
So for RHEL8 (or compatible) it needs to be version 4.2.1.  For RHEL 9 it needs to be 4.10.0

We need to start with the correct version of fence-agents and work from there.


On Wed, Jul 27, 2022 at 10:03 AM Alex Talaran <atalaran@gmail.com> wrote:
i was able to get this built and installable if anyone wants to help
test or maintain it.
an issue exists with the man pages not being built still but im not sure
how the makefile target works for these so they are excluded for now.

maybe some other small tweaks are still needed too since its just a
(first for me) stripped down and modified upstream spec file.

On 2022-07-20 08:47, Andrew C Aitchison wrote:
> On Wed, 20 Jul 2022, Alex Talaran wrote:
>> i ended up with the same error with that change.
> I am sorry my suggestion did not help.
> I don't have a Red Hat compatible machine newer that RHEL6
> (I moved to Ubuntu for work-related reasons)
> so I am unable to test things myself.
>> is it possible its getting confused because the dirname in the tarball
>> is different than the package name and looking in the wrong spot?
> The -n fence-agents-%{version} in
>      %prep
>      %setup -q -n fence-agents-%{version}
> is supposed to resolve that, but that setup line might need tweaking
> to match the contents of the tarball.
> It is old and may be somewhat dated, but my bible for rewriting .spec
> files was the book
>     Maximum RPM - Taking the Red Hat Package Manager to the Limit
> a version of which is available at
>      http://ftp.rpm.org/max-rpm/index.html
>> On 2022-07-19 23:32, Andrew C Aitchison wrote:
>>> On Tue, 19 Jul 2022, Alex Talaran wrote:
>>>> per a previous thread i took a shot at cleaning up the fence-agents
>>>> rpm to only include the missing agents and make a new package. i am
>>>> having some issues with the source url and getting it to build. the
>>>> srpm is ok, but when i try to rebuild it into a proper rpm i get the
>>>> following (output truncated):
>>>> ---
>>>> + py39_byte_compile /usr/bin/python3
>>>> /builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence
>>>> + python_binary='env PYTHONHASHSEED=0 /usr/bin/python3'
>>>> +
>>>> bytecode_compilation_path=/builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence
>>>> + env PYTHONHASHSEED=0 /usr/bin/python3 -s -B -m compileall -o 0 -o
>>>> 1 -s /builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64
>>>> -p /
>>>> /builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence
>>>> Listing
>>>> '/builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence'...
>>>> Can't list
>>>> '/builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence'
>>>> + chmod 0755
>>>> /builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_pve.py /builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_raritan.py /builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_rcd_serial.py /builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_virsh.py
>>>> chmod: cannot access
>>>> '/builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_pve.py': No such file or directory
>>>> chmod: cannot access
>>>> '/builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_raritan.py': No such file or directory
>>>> chmod: cannot access
>>>> '/builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_rcd_serial.py': No such file or directory
>>>> chmod: cannot access
>>>> '/builddir/build/BUILDROOT/fence-agents-epel-4.11.0-1.el9.x86_64/usr/share/fence/fence_virsh.py': No such file or directory
>>>> error: Bad exit status from /var/tmp/rpm-tmp.S10L6D (%install)
>>>> ---
>>>> i even tried to comment out the bytecompile lines but got the same
>>>> error.
>>>> is it possible to get some help sorting this out? i have attached
>>>> the WIP spec file.
>>>> thank you.
>>> I would try replacing
>>>      mkdir -p %{buildroot}/%{_datadir}/
>>> with
>>>      mkdir -p %{buildroot}/%{_datadir}/fence
> _______________________________________________
epel-devel mailing list -- epel-devel@lists.fedoraproject.org
To unsubscribe send an email to epel-devel-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/epel-devel@lists.fedoraproject.org
Do not reply to spam on the list, report it: https://pagure.io/fedora-infrastructure