Mark, your new changed patch looked good to me.
It does not matter to me if INTUSE is changed now or later.

On Tue, Nov 3, 2015 at 2:58 PM, Mark Wielaard <> wrote:
On Tue, Nov 03, 2015 at 03:58:10PM +0100, Mark Wielaard wrote:
> Although the dwfl_module_getsrc_file.c change itself is good, the abuse
> of INTUSE to define and use a "not really" libdw dwarf_line_file
> function (which really is just dwarf_linesrc with the two unused return
> values dropped) was just too ugly. Sorry, I know you didn't introduce
> this (it looks like it has been this way forever). I'll propose
> something that doesn't hurt my eyes so much.

At first I thought we should introduce a new libdw line function or
make an exiting one easier for what dwfl_module_getsrc_file needs.
But this seems a little too specific. It might be better to wait till
we start supporting the the new DWARFv5 line tables which will need
new functions to support anyway.

So lets just use what you came up with, but just rename the function
and drop the strange INTUSE usage. Attached your patch with just that