I did the following and error went off . All test pass now .

1. get the latest elfutils
wget http://mirror.pnl.gov/fedora/linux/updates/21/SRPMS/e/elfutils-0.161-2.fc21.src.rpm

2. perform the rpmbuild of elfutils
rpmbuild --define "%_topdir `pwd`" -ba SPECS/elfutils.spec


From:        Mark Wielaard <mjw@redhat.com>
To:        Ashish Kumar9/India/IBM@IBMIN
Cc:        elfutils-devel@lists.fedorahosted.org
Date:        01/20/2015 08:11 PM
Subject:        Re: elfutils build error on fedora 19 ppc64
Sent by:        elfutils-devel-bounces@lists.fedorahosted.org




On Tue, 2015-01-20 at 15:34 +0530, Ashish Kumar9 wrote:
> I am trying to build elfutils package on Fedora 19 on ppc64 server .

Note that Fedora 19 isn't supported anymore. You might want to upgrade
to a supported version like f20 or f21.

> During the build , I am observing few unit test failure issues as below
> .However the community ppc build indicates successful build .
>
> Is there any specific settings to be adopted to get the build successful ?

In general tests should all PASS (or SKIP if something is unsupported on
the particular platform/arch) with a normal make check without needing
any specific settings.

It looks like you are trying to build version 0.158 which is more than a
year old now. Please try with the latest elfutils 0.161 release (or
current git) to make sure the issues haven't already been fixed.

Cheers,

Mark