On 08/08/13 03:47, Adam Williamson wrote:
On Thu, 2013-08-08 at 10:43 +0800, Christopher Meng wrote:
> Just a note, I find my package's deps have magic requires for
> 5.16.2(not 5.16.3), does it mean that this has not rebuilded since
> f19? Why?
It means they failed or got superseded from the perl 5.18 rebuild for
some reason. Instead of asking others to spend their time for you, why
not find out for yourself? All you have to do is go to Koji, search for
each package, and look through the recent builds to see what was going
In this case it's because your package depends on various perl-Catalyst
packages, which are in turn not buildable because one of their
dependencies is incompatible with Perl 5.18.
Many of these packages have now got blocks/depends on data included in
their FTBFS bugzilla tickets, which make it easier to track why
particular packages aren't built, and provide notifications when an
underlying dependency has been fixed.