First of all I love the new GNOME 3.16 release.  The notifications and system tray icons (in the left) are great and productivity boosters.  However, I'm having some issues with Intel HD graphics on X11 that make things very difficult.  Though these problems are solved by the Wayland session it's still too unstable for me to use in production as a day-to-day desktop.

Intel® Core™ i5-4200M CPU @ 2.50GHz × 4
Intel® Haswell Mobile (HD 4600, i965) 

Version 3.16.2



At work I use two external monitors in addition to the laptop screen.  VSYNC often breaks when using either SNA or UXA at random intervals.  It also breaks also when I fullscreen any application in any monitor.  Even when I force VSYNC in both xorg.conf and drirc it doesn't seem to help.

These are configurations for reference:


Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
  Option      "AccelMethod" "sna"
  Option      "TearFree" "true"
  Option      "SwapbuffersWait" "true"

<device screen="0" driver="i965">
<application name="Default">
            <option name="force_s3tc_enable" value="true" />
            <option name="no_rast" value="false" />
            <option name="always_flush_batch" value="false" />
            <option name="always_flush_cache" value="false" />
            <option name="shader_precompile" value="true" />
            <option name="hiz" value="true" />
            <option name="clamp_max_samples" value="-1" />
            <option name="bo_reuse" value="1" />
            <option name="allow_glsl_extension_directive_midshader" value="false" />
            <option name="force_glsl_extensions_warn" value="false" />
            <option name="disable_throttling" value="false" />
            <option name="disable_glsl_line_continuations" value="false" />
            <option name="disable_blend_func_extended" value="false" />
            <option name="vblank_mode" value="3" />

I even have a GNOME extension I created that autoloads the following GNOME JS function: 

This still doesn't help at all.  There is a bug report for this item and has been confirmed but I haven't heard anything and status is still NEW and not yet confirmed.  Please, any help on this would be appreciated. Things like this should just work out of the box especially on Intel HD graphics. This is a bewildering problem as this is my work machine and I may end up switching to a Mac or Ubuntu Unity if this cannot be fixed. 

Thank you!