On 17.02.2014 09:02, Marius Vollmer wrote:
Jan Safranek <jsafrane(a)redhat.com> writes:
> The protocol looks usable, I would only add also 'protocol
> version' field, this can save a lot of headache when you consider
> moving from json to something else.
I think we can include that in the "protocol" string, if necessary.
Yes. Did that. Although it's now called "payload" to make it clearer
what it's about.
Updated documentation here:
Merge request here for initial work on this:
Out of curiosity, are there any alternative already defined/used
This is really about framing and control commands, over a text based
transport (ie: old WebSockets). It ends up being pretty Cockpit
specific. Nothing else comes to mind that would fit well here.