Seems like my problems with F25 a year ago, so here is what I did, sorry for lack of details (I'll access the HW within next couple of hours) - SD Card does matter: I used some budget Sandisk  (class 10 I believe) worked really slow. I moved to some Samsung Evo (class 10 as well - much better).
I also observerd an improvement when I changed io scheduler to noop. Also an upgrade from 25 to 26 improved a lot. Now hearing You have problems with 27 I'm i doubt... I was about to upgrade this week.
When I was investigating this problem with nmon I've foud that systemd-journald is responsible for "heavy" IO. Does it perform IO synchronously ?

2018-01-24 5:50 GMT+01:00 linux guy <>:

The dnf update process is still very, very slow on the RPi3.  It will take all night (8 hours) to run.   For comparison, I installed F27 workstation on a Celeron N3000 machine with 2 GB of RAM and a 128 GB SSD earlier this week.  A much larger (workstation versus minimal server) dnf update took in the order of 10 minutes on that machine.  I don't think the I/0 speed and processing power difference is an order of 1000 between these two machines.  

I ran $top in another console while #dnf update was running.   dnf is rarely at the top of the top listing.  And when it is, it is using ~40% of the CPU and only 12% of the memory.  None of the swap memory is being used at all.  90% of the time $top itself is the largest resource user.

So why is the #dnf update process so slow ?  Is it I/O bound ?  Is it an I/O access algorithm problem ?

On Tue, Jan 23, 2018 at 9:00 PM, linux guy <> wrote:
So I checked a few things.

My SD card was a Kingston 16 GB Class 10, rated for 45MB/sec.  It should be OK.

The power adapter was a Samsung unit rated at 2A at 5V.   I replaced it with a unit rated at 2.4A at 5.25V.

I rewrote the SD card.  I used gparted to resize the root partition to be the remainder of the space on the card.  It was 3.2GB with 2.3 GB used.  Now it is ~12GB with 2.3 GB used.  I wanted to resize the swap partition, which is set to 488 MB.  For some reason gparted wouldn't let me touch it.  

I rebooted and reinitialized things.  It runs much, much faster, but it still seems slow.  Each package upgrade in #dnf upgrade is probably taking a minute now, versus 5 minutes before. 

arm mailing list --
To unsubscribe send an email to


/* tough guys don't do backup */