Just noticed this has been sitting my drafts file for a while

Everything is working now on PcDuino3_Nano, except for initial setup scripts.  I'm not sure why.  After I get things booted up (by removing the startup links for the initial setup stuff) I am able to run them by hand. 

Image used: Fedora-LXDE-armhfp-23-20150815-sda.raw.xz
Kernel: 4.2.0-0.rc5.git0.2.fc23

Boots into a graphical LXDE desktop, correct resolution, network works.  I currently haven't found anything that doesn't work but I have not done extensive testing.

I'll try a newer image to see if the initial setup scripts are working  ... but it might be a week before I get the time.

Troy Dawson

On Sat, Jul 25, 2015 at 9:33 PM, Troy Dawson <tdawson@redhat.com> wrote:

On Sat, Jul 25, 2015 at 2:10 AM, Peter Robinson <pbrobinson@gmail.com> wrote:
>> On Thu, Jul 9, 2015 at 10:54 PM, Troy Dawson <tdawson@redhat.com> wrote:
>> > Hi,
>> > I just wanted to report that F22 works very well on the PcDuino3 Nano.
>> > In
>> > fact, I installed the LXDE image, and this is the first time I've seen
>> > the
>> > graphical startup screen.
>> Thanks for the report, it's nice to hear success stories :)
>> > There are a few things to note.
>> > 1 - The graphics were at the lowest res and couldn't get any higher.
>> > (Was
>> > expecting this)
>> Sadly we have no idea when this situation might improve due to the
>> MALI chipset still currently being closed.
>> > 2 - I haven't tested the SATA yet (need to get the cables)
>> > 3 - I am using the pcduino uboot and kernel
>> Looking at 4.2 and u-boot 2015.07 we have both u-boot support
>> (Linksprite_pcDuino3_Nano) and DT (sun7i-a20-pcduino3-nano.dtb) for
>> it. Not sure how much is there but it should be on a par with the rest
>> of the A20 support.
>> > So, not 100%, but I'm not expecting that until it's patch hits the
>> > mainstream kernel. (Hoping 4.3)
>> There's at least some in 4.2 I'd be interested in hearing how you get
>> on with a vanilla F-23 image if you're feeling brave.
>> Thanks for the feedback.
>> Peter
> That is great.  I'm very excited to see it in both uboot and the kernel.
> Results thus far:
> image: Fedora-LXDE-armhfp-23-20150724-sda.raw.xz
> Installed image the xzcat | dd way
> Installed uboot  by cd
> <mountpoint>/usr/share/uboot/Linksprite_pcDuino3_Nano/
>   dd if=u-boot-sunxi-with-spl.bin of=/dev/sdc bs=1024 seek=8
> (There was also u-boot.bin u-boot.dtb and u-boot.img in there, but
> u-boot-sunxi-with-spl.bin was what I was using before so I stuck with it)
> Stuck sd card into pcDuino and powered it on.
> Booted into U-Boot 2015.07
>  - Both hdmi, and usb keyboard worked in uboot land
> Got the following
> Fedora-Minimal-armhfp-23-20150724 Boot Options.
> 1:  Fedora-Minimal-armfp-23-20150724 (4.2.0-0.rc3.git3.1.fc23.armv7hl)
> Enter choice: 1
> 1:  Fedora-Minimal-armfp-23-20150724 (4.2.0-0.rc3.git3.1.fc23.armv7hl)
> Retrieving file: /initramfs-4.2.0-0.rc3.git3.1.fc23.armv7hl.img
> and off it went.
> It was originally failling to read the initrd at this point (which is why I
> had this typed out), but I installed the image on a different sd card and
> things worked.
> It did originally dis not not startup the graphics. In the end this was
> because the initial-setup was crashing.
> After I got initital-setup turned off and did some tests in mult-user, I
> switched back to graphical, and it booted right up into LXDE.
> Plus, it booted into the proper resolution (1920x1200).
> You might not be able to tell but "I AM EXCITED!! THANK YOU!!" :)

Awesome to hear :)

> So, what's broken.
> 1 -networking

Known issue, I thought I had fixed this, but clearly not, will look
again next week when I'm back near devices :-/

> 2 - initial-setup  "ImportError: No module named pyanaconda.users

Known issue, this is already a blocker bug for Alpha (rhbz 1244558)

> I might be missing something with the networking, but all the poking I do is
> acting like there isn't anything there.

If you do a "dmesg | grep stmmac" you should see the errors, it might
actually be fixed with rc4 but I'm not so sure now.

Sure enough, there are the errors.
[   10.346886] stmmac_platform: module license 'unspecified' taints kernel.
[   10.384361] stmmac_platform: Unknown symbol devm_kmalloc (err 0)
[   10.402972] stmmac_platform: Unknown symbol stmmac_suspend (err 0)
[   10.457932] stmmac_platform: Unknown symbol platform_get_irq_byname (err 0)
[   10.500390] stmmac_platform: Unknown symbol stmmac_dvr_remove (err 0)
[   10.518494] stmmac_platform: Unknown symbol platform_get_resource (err 0)
[   10.556284] stmmac_platform: Unknown symbol of_get_phy_mode (err 0)
[   10.574109] stmmac_platform: Unknown symbol of_property_read_u32_array (err 0)
[   10.620479] stmmac_platform: Unknown symbol of_alias_get_id (err 0)
[   10.620504] stmmac_platform: Unknown symbol stmmac_resume (err 0)
[   10.620522] stmmac_platform: Unknown symbol stmmac_dvr_probe (err 0)

 It's possible rc4 has the fix, this is rc3

> How would I determine if somehow the network driver / hardware isn't being
> loaded versus some userside configuration issue?

I'm 95% sure it's kernel and that we're seeing it on all Allwinner
devices, I'll get it fixed next week one way or the other. USB network
should work if you want to keep F-23 and have networking, else watch
this space next week.

I look forward to testing it on next weeks image, or whenever rc4 hit's the images.


> Troy
>> > Thank you to everyone who helped F22 work so well.
>> >
>> > Troy Dawson
>> > p.s. I'm planning on trying out the rawhide uboot, I'm very excited
>> > about
>> > the 2015.07 uboot. Hopefully will have some time this weekend.
>> > p.p.s. Until the pcduino3 patch makes it in the kernel, here is how to
>> > install fedora on one
>> > http://www.yortnoswad.org/blog/2014/10/29/fedora-on-pcduino3-nano/
>> >
>> > _______________________________________________
>> > arm mailing list
>> > arm@lists.fedoraproject.org
>> > https://admin.fedoraproject.org/mailman/listinfo/arm