Good Morning, Alexander,

On 2/23/18 5:27 AM, Alexander Chernov wrote:

I've been trying to install Fedora 27 to Raspberry Pi2, Raspberry Pi3,
and Orange Pi Plus 2 without any success.

Generally, the kernel boots then service initialization starts, but
does not complete. For example, the latest attempt at booting Fedora
27 Server on Orange Pi Plus 2 stopped at the following:

[  OK  ] Reached target Basic System.
         Starting Initial Setup configuration program...
[  OK  ] Started Hardware RNG Entropy Gatherer Daemon.
         Starting OpenSSH rsa Server Key Generation...
         Starting ABRT Automated Bug Reporting Tool...
         Starting GSSAPI Proxy Daemon...
         Starting Authorization Manager...
         Starting OpenSSH ecdsa Server Key Generation...
         Starting System Security Services Daemon...
         Starting NTP client/server...
         Starting OpenSSH ed25519 Server Key Generation...
         Starting System Logging Service...
[  OK  ] Started Self Monitoring and Reporting Technology (SMART) Daemon.
[  OK  ] Started D-Bus System Message Bus.
[  OK  ] Started irqbalance daemon.
[  OK  ] Started System Logging Service.

... and nothing more on serial console.

Any help would be appreciated.

    I've been running F27-aarch64 on RPi-3B so might be able to help if that's what you're using.

    Are you using the 32-bit or 64-bit version?  Workstation, server, or minimal distro? 

    I was really only interested in the 64-bit version, and I really wanted the ability to run with a GUI
interface from time to time.  I've installed both workstation and minimal and
upgraded through kernel 4.15.3-300.  I had no problems booting from install, but the GUI interface
was never stable ... gave up on it.  Tried XFCE over the minimal install with the same result.
But in all cases, F27 booted from the first install, and I could ssh into the system (my router
is set to assign static IPs to my Pis' MAC addresses).  If I "systemctl set-default multi-user.service"
from an ssh session and then reboot, the Pi boots up into F27-aarch64 and presents a CLI login
prompt.  System performs reasonably and reliably.  Just can't use the GUI.

    I've abandoned F27-aarch64 for now and returned to openSUSE Leap 42.3 for now ... similar
CLI performance and solid XFCE GUI. 

    But I'd be happy to help if you're working to install F27-aarch64 on RPi-3B -- the experience is
still fresh (raw?) in my mind.  Can't help much beyond that.

David Todd