heh, possibly software update didn't like me because I forgot to resize the root partition. :) I don't know if it does a free space check prior to downloading or not.

From: Sean Omalley <omalley_s@rocketmail.com>
To: "arm@lists.fedoraproject.org" <arm@lists.fedoraproject.org>
Sent: Monday, January 30, 2017 6:06 PM
Subject: RPI3 -workstation, didn't update with GUI

I got the RPI3. Grabbed the F25 1-3 workstation image.

I am having issues with the logitech k400 keyboard not working working inside gui applications I tried terminal and firefox.  I can log in fine, but I open up terminal, and it wont take any keystrokes. The mouse part still works.
I clicked the software update hoping the previously mentioned issue would be fixed. It didn't update. I tried twice, I was able to login via ssh, and I am upgrading 483 packages.

I am using an external usb wireless device since according to the docs the internal wireless doesn't work.

What are the issues with the internal wireless and the gpio pins? is it solvable or is there a page (or information) on what needs to be done to get it to work?