A long time ago (last December) I reported a problem with Dreamplug  at least 3.6.10 through to 3.7.5 suffering from the kernel reporting a soft lockup when I doing a git pull when it was anything but a small update over the network - see https://bugzilla.redhat.com/show_bug.cgi?id=910593 . The advice then was to upgrade to a 3.8 kernel, but due to the challenges of trying to get my head around device tree it got pushed to the back of the drawer. Now, I am trying to get Postfix working, and I am finding that it appears to be causing the kernel to hang up too, so I need to get the upgrade done. Although git, and probably Postfix, cause the lockup, I have not experienced any other activity that does; ssh, ftp, yum update for example all appear to work without a problem.

Over the last couple of days I have been working on upgrading to the latest Fedora kernel available, so I have been using 3.10.10. Although the kernel is no longer reporting a soft lockup, when I try doing a git pull, just about the moment git reports that it is starting to transfer data the kernel completely stops responding; there is no output on the console, no output on the terminal where I am running git, and it won't respond to any keyboard input or pings. After a minute, the watchdog kicks in and reboots the dreamplug, and I have not managed to find any entries in any logs that relate to the hangup.

I had previously assumed that this was a generic problem, but I have tried a different kernel build, from http://www.xilka.com/sheeva/kernel/3/ . I have tried both 3.10.9 and 3.11.1, i.e. kernels both before and after the Fedora kernel 3.10.10 kernel I was trying. Both of the xilka kernels work fine with git.

So it seems to me that the problem must be in the Fedora config/patches/build somewhere.

What should I do from here? Simply filing it as a bug at this stage probably isn't helpful, due to the lack of information. What can I do to help track down the cause of the problem, and hence get a resolution?