On Wed, Nov 22, 2017 at 11:46 AM, Peter Robinson <pbrobinson@gmail.com> wrote:
On Wed, Nov 22, 2017 at 9:37 AM, Ashwin Rao <ashwin.shirvanthe@gmail.com> wrote:
> Hi,
> When running the aarch64 Workstation, Server, and Minimal images I am not able to see the initial setup wizard. I can see the messages shown during boot but after some time the screen either starts to flicker or  just blanks out. I tried this on 3 different raspberry Pis with different cards and the result is always the same.
> The steps I followed are
> 1.  I downloaded the aarch64 images from [ https://fedoraproject.org/wiki/Architectures/ARM/Raspberry_Pi#Raspberry_Pi_3_aarch64_support ] and followed the instructions mentioned on the same web page to prepare the images using xzcat.
> 2. I connect the HDMI cable of my monitor, and connect the keyboard and mouse. I am not connecting an Ethernet cable.
> 3. I can see the boot screen, and the messages showing that the device is booting.
> 4. After some time the screen either blanks out or starts to flicker. I have tried it with different monitors and different power supplies as well but the result is the same. I noticed that the red LED of the Raspberry Pi also starts to blink abruptly.
> I am able to use Raspbian and OpenSuse using the same Raspberry Pis so I doubt there is an issue with the card, the power supply, or with the Pis.
> It would be nice if someone suggests the things I need to do, or if someone was able to troubleshoot similar issues.

The problem is with either the monitor or the HDMI cable, the VC4 open
driver (which neither of the other distros use yet) can be a bit
fragile with some EDID responses from some monitors or cables (yes
we've had people with issues that were fixed when they swapped the
HDMI cable). It's improved a lot since F-25 when we first started
supporting the RPi but it's not perfect yet.

On the case of Server and Minimal if you never want to use a graphical
interface and are happy with just the text console you can add a
blacklist so the GPU driver isn't laoded on boot. This can be done by
adding blacklist=vc4 to the kernel command line or creating a file
/etc/modprobe.conf/vc4.conf with the line "blacklist vc4"

Thank you for the suggestion. I currently do not need the graphical interface, so I tried again with the Server image. 
Adding module_blacklist=vc4 instead of blacklist=vc4 to the kernel command line allowed me to get to the login prompt.
-- Ashwin