On Fri, Jul 24, 2015 at 9:25 AM, Peter Robinson <pbrobinson@gmail.com> wrote:
Hi Troy,

On Thu, Jul 9, 2015 at 10:54 PM, Troy Dawson <tdawson@redhat.com> wrote:
> Hi,
> I just wanted to report that F22 works very well on the PcDuino3 Nano.  In
> fact, I installed the LXDE image, and this is the first time I've seen the
> graphical startup screen.

Thanks for the report, it's nice to hear success stories :)

> There are a few things to note.
> 1 - The graphics were at the lowest res and couldn't get any higher. (Was
> expecting this)

Sadly we have no idea when this situation might improve due to the
MALI chipset still currently being closed.

> 2 - I haven't tested the SATA yet (need to get the cables)
> 3 - I am using the pcduino uboot and kernel

Looking at 4.2 and u-boot 2015.07 we have both u-boot support
(Linksprite_pcDuino3_Nano) and DT (sun7i-a20-pcduino3-nano.dtb) for
it. Not sure how much is there but it should be on a par with the rest
of the A20 support.

> So, not 100%, but I'm not expecting that until it's patch hits the
> mainstream kernel. (Hoping 4.3)

There's at least some in 4.2 I'd be interested in hearing how you get
on with a vanilla F-23 image if you're feeling brave.

Thanks for the feedback.


That is great.  I'm very excited to see it in both uboot and the kernel.
Results thus far:
image: Fedora-LXDE-armhfp-23-20150724-sda.raw.xz
Installed image the xzcat | dd way
Installed uboot  by cd <mountpoint>/usr/share/uboot/Linksprite_pcDuino3_Nano/
  dd if=u-boot-sunxi-with-spl.bin of=/dev/sdc bs=1024 seek=8
(There was also u-boot.bin u-boot.dtb and u-boot.img in there, but u-boot-sunxi-with-spl.bin was what I was using before so I stuck with it)
Stuck sd card into pcDuino and powered it on.
Booted into U-Boot 2015.07
 - Both hdmi, and usb keyboard worked in uboot land

Got the following
Fedora-Minimal-armhfp-23-20150724 Boot Options.
1:  Fedora-Minimal-armfp-23-20150724 (4.2.0-0.rc3.git3.1.fc23.armv7hl)
Enter choice: 1
1:  Fedora-Minimal-armfp-23-20150724 (4.2.0-0.rc3.git3.1.fc23.armv7hl)
Retrieving file: /initramfs-4.2.0-0.rc3.git3.1.fc23.armv7hl.img
and off it went.
It was originally failling to read the initrd at this point (which is why I had this typed out), but I installed the image on a different sd card and things worked.

It did originally dis not not startup the graphics. In the end this was because the initial-setup was crashing.
After I got initital-setup turned off and did some tests in mult-user, I switched back to graphical, and it booted right up into LXDE.
Plus, it booted into the proper resolution (1920x1200).

You might not be able to tell but "I AM EXCITED!! THANK YOU!!" :)

So, what's broken.
1 -networking
2 - initial-setup  "ImportError: No module named pyanaconda.users

I might be missing something with the networking, but all the poking I do is acting like there isn't anything there.
How would I determine if somehow the network driver / hardware isn't being loaded versus some userside configuration issue?


> Thank you to everyone who helped F22 work so well.
> Troy Dawson
> p.s. I'm planning on trying out the rawhide uboot, I'm very excited about
> the 2015.07 uboot. Hopefully will have some time this weekend.
> p.p.s. Until the pcduino3 patch makes it in the kernel, here is how to
> install fedora on one
> http://www.yortnoswad.org/blog/2014/10/29/fedora-on-pcduino3-nano/
> _______________________________________________
> arm mailing list
> arm@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/arm