On Sat, Mar 25, 2017 at 2:46 PM, Miro Hrončok <mhroncok@redhat.com> wrote:
On 25.3.2017 05:00, Fulko Hew wrote:
Running on F25, I installed cura. (15.04.4-5.fc25)
(I have tried slic3r and haven't figured out how to tune it to get
usable gcode.)
(And I can't figure out skeinforge.)

On cura, the button the docs tell me is the 'save' button' doesn't have
an icon
and isn't clickable. And the 'Save Gcode' menu item doesn't appear to do
anything either.

What am I missing ?

I'm not sure. It works for me.

When you run cura from the command line, what does the output there say?

​I've spent the morning playing and researching.
Someone had the same issue, and a reply to them told them to connect
the USB to their printer.  I did that, and the save/print button now
appears, and the menu item now works.  It also seems to work with
it disconnected now.  I guess, it needed to be connected at least once
in order to work.

I then sliced my test cube, and the slicing looked nice,
not like what I got out of slic3r.

I wish I knew how to get slice3rto generate nice slices that print usable
objects. So far I'm shooting in the dark.  The first and biggest issue is
it doesn't seem to extrude enough material. And I don't know what I can
adjust to affect that.

I also tried selecting skeinforge from repetier's menus; it generated
some kind of gcode, but repetier wouldn't render it. (and no, nothing
showed when invoked from the console.

(All this is with the packaged repetier/slic3r/skeinforge from Fedora.)