I setup central authentication using centos ds.  On a test box I got it working just the way i wanted, but then when I went to deploy the config files to some other servers,  things went screwy.
Hopefully someone else has seen this happen when deploying ldap..??

Heres what I did.
1.  Copied my config files from the working server to a new one. Here is a listing of the files that have been copied:

2. Once the files are in place, I tried to ssh as username "dumbo" uid=1000 in ldap.  I can login successfully, but the bash environment is all screwed up.   Here is what i mean by that.
example 1.   echo hello |grep hello      returns no output.   No pipes seem to work.  grep alone on a file works.
example 2.  See the attached zip file.  I saved the output of bash --login -vx  from both a local user and an ldap user.  It appears that when the ldap user logs in, it is unable to parse backticks. Note the output is just 50 lines, which shows what happens when the user runs /etc/bashrc on login.

Some other steps i've taken.
1. wiped out the home directory for the ldap user (although it still worked fine on my first test box).
2. diffed and confirmed that all of the files i copied as well as /etc/profile.d  are identical on both servers.
3. I set the first line in /etc/bashrc to  "set > /tmp/test1", and compared output of the environment variables from a local and ldap user.  The output is is the same other the of course the UID's and PID numbers.

I am at a complete loss as to what the problem is.

any help would be appreciated. Thanks!