I’ve quickly checked the archive and I can find people having trouble with users changing their own password but not the other way around.  Here, users can change their own password without issue but root fails.  What do I need to do to allow root, using the passwd command on RHES 4, to change user passwords?


I’ve tried setting rootbinddn in my /etc/ldap.conf file.  Without an /etc/ldap.secret file, I observe an error in my logs, complaining about the missing ldap.secret file.  When I create it, the error goes away but the passwd command still fails with, “passwd: Authentication token manipulation error”.  In the logs I can observe, “passwd[23689]: pam_ldap: error trying to bind (Invalid credentials).”  I’ve tried placing the admin password in cleartext, and base64 in the ldap.secret file.


Frankly, I’d rather root be prompted for the LDAP admin password than the password be stored in a file anyways.  Is this possible?


Long of the short, what do I need to configure to allow root to change other user’s LDAP passwords?




Best Regards,


Greg Copeland