Hi team,
I've updated the contribution docs as I've tried to remove the confusion :)


Hope that helps,

On Tue, Feb 23, 2021 at 7:42 PM Ludwig Krispenz <krispenz@t-online.de> wrote:

since a long time I was trying to build rpms and failed, here are the
issues I run into:

1] problem with npm/audit

I followed the suggestions here:
https://www.port389.org/docs/389ds/contributing.html (pushd/npm
fix/popd), but this didn't help, only commenting out audit-ci in
src/cockpit/389-console/node_modules.mk got me over this

2] rust


rpm build failed with:

error: failed to get `concread` as a dependency of package `librslapd

Caused by:
   failed to load source for dependency `concread`

Caused by:
   Unable to update registry `https://github.com/rust-lang/crates.io-index`

Caused by:
   failed to update replaced source registry

Caused by:
   failed to read root of directory source:

Caused by:
   No such file or directory (os error 2)
make[1]: *** [Makefile:12715:
Error 101


It was right that there wasno rs/rslapd/release/librslapd.a file, not
even the directory rs existed. After configuring --enable-rust the
directory was created and populated.

Q1: why does it try to pack rust stuff if it is not enabled ?

2.2] Now the directory was there, but I still did get the same error. A
closer look showed that it was looking for
,but what existed was
Note "debug" -- "release". configure was run with --enable-debug

Q2: Is there somewhere a hardcoded/default assumpion of "release" ? in
the cargo spec?

Thanks for any suggestions


389-devel mailing list -- 389-devel@lists.fedoraproject.org
To unsubscribe send an email to 389-devel-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/389-devel@lists.fedoraproject.org
Do not reply to spam on the list, report it: https://pagure.io/fedora-infrastructure