[SSSD] [PATCH] DNS site support 1st wave - generic SRV lookup plugin

Pavel Březina pbrezina at redhat.com
Fri Mar 22 13:47:31 UTC 2013


Hi,
this patchset takes the current SRV lookup code and converts it into a
plugin. Next waves will add custom plugin for IPA and AD.

Patch 1:
Introduce new plugin interface.

Patch 2:
First SRV lookup plugin.

Patch 3:
Replaces current code with a plugin code. I originally wanted to remove
resolve_srv_* functions completely and call the plugin in
fo_resolve_service_send() directly but that proved to be harder and
more error sensitive than I expected.

This got me thinking, we should create a refactoring ticket for the
failover code. It has become quite complex and hard to read and
understand because it lacks a lot of comments. Also many things there
seems very hackish to me.

Patch 4:
Set SRV lookup plugin for all providers. This is done as a separate
patch because it will be reverted once each provider has its own plugin.

I also would like to discuss where we can set the plugin in the future.
At the moment we have one failover context for the whole backend. But
the backend can be configured to run several different providers at the
same time. The plugin itself is made per provider - you have different
plugin for IPA and different for LDAP.

I think we should have failover context per provider. My idea is to
create a new module constructor e.g. sssm_ipa_init(). This will be
called only once before all other sssm_ipa_*_init() functions and it
will initialize IPA-wise failover context.

We can also use it to initialize sdap_id_ctx instead of calling
sssm_ipa_id_init from other places.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-DNS-sites-support-SRV-lookup-plugin-interface.patch
Type: text/x-patch
Size: 4786 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20130322/378d09ce/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0002-DNS-sites-support-simple-SRV-lookup-plugin.patch
Type: text/x-patch
Size: 22347 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20130322/378d09ce/attachment-0001.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0003-DNS-sites-support-replace-SRV-lookup-code-with-a-plu.patch
Type: text/x-patch
Size: 16705 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20130322/378d09ce/attachment-0002.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0004-DNS-sites-support-use-simple-SRV-lookup-plugin-for-a.patch
Type: text/x-patch
Size: 3791 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20130322/378d09ce/attachment-0003.bin>


More information about the sssd-devel mailing list