[PATCH] BZ 794505: lower cost hwp for ec2

Scott Seago sseago at redhat.com
Mon Mar 5 18:38:05 UTC 2012


On 03/05/2012 01:15 PM, mzatko at redhat.com wrote:
> From: Maros Zatko<mzatko at redhat.com>
>
> https://bugzilla.redhat.com/show_bug.cgi?id=794505
>
> * 'hwp1' was matching an expensive xlarge instance
> * changed 'hwp1' to match 'm1.large - x86_64, 7680 ram, 850gb, 4cpu'
> * added 'small' profile '500mb, 1cpu, blank gb, x86_64'
>    which matches 'm1.large - x86_64, 7168 ram, 1690gb, 20cpu'
> ---
>   recipes/aeolus/manifests/profiles/ec2.pp |   11 +++++++++--
>   1 files changed, 9 insertions(+), 2 deletions(-)
>
> diff --git a/recipes/aeolus/manifests/profiles/ec2.pp b/recipes/aeolus/manifests/profiles/ec2.pp
> index cbaa52d..337954a 100644
> --- a/recipes/aeolus/manifests/profiles/ec2.pp
> +++ b/recipes/aeolus/manifests/profiles/ec2.pp
> @@ -69,7 +69,14 @@ class aeolus::profiles::ec2 {
>         require        =>  Aeolus::Conductor::Login["admin"] }
>
>     aeolus::conductor::hwp{"hwp1":
> -      memory         =>  "512",
> +      memory         =>  "7500",
> +      cpu            =>  "1",
> +      storage        =>  "",
> +      architecture   =>  "x86_64",
> +      require        =>  Aeolus::Conductor::Login["admin"] }
> +
> +  aeolus::conductor::hwp{"small":
> +      memory         =>  "500",
>         cpu            =>  "1",
>         storage        =>  "",
>         architecture   =>  "x86_64",
> @@ -78,5 +85,5 @@ class aeolus::profiles::ec2 {
>     Aeolus::Conductor::Provider<| |>  ->  Aeolus::Conductor::Logout<| |>
>
>     aeolus::conductor::logout{"admin":
> -    require    =>  [Aeolus::Conductor::Hwp['hwp1']] }
> +    require    =>  [Aeolus::Conductor::Hwp['hwp1'], Aeolus::Conductor::Hwp['small']] }
>   }
Small HWP needs to  be i386, or it will match c1.xlarge just like 'hwp1' 
used to.

Also, should we rename hwp1 to 'x86_64 hwp' and small to 'i386' -- since 
that's the main difference?

Scott




More information about the aeolus-devel mailing list